Our mobile JobWalk App is an essential part of the documentation process on any site. Therefore, it is important that it works seamlessly with any electronic device you might be using for the actual JobWalk.

NOTE: If you are using the HoloBuilder EU server solution you will need to download the JobWalk app for EU for Android or iOS.

Although we do already support most any android device, you might still be confronted with compatibility issues if you are not using a device with certain chip manufacturers combined with some Android versions.

In these cases, when trying to download the app in the App Store, you will get a notification that your device is not compatible and will not be able to download the app.

Why am I not able to download the JobWalk App in the PlayStore?

As mentioned, there are some Android devices that are not supported by the HoloBuilder JobWalk App. If this is the case for your device, here is why:

Different Android devices use different CPUs, which in turn support different instructions sets. Each combination of CPU and instruction set has its own Application Binary Interface (ABI).

The upload of an app to the PlayStore is limited at a given size. Since the size of our app file for certain configurations, we need to upload the different ABI versions individually (as split APKs) in order to comply with the upload limit.

There are 2 ABI Android combinations that we support via the PlayStore:

  1. armeabi-v7a with Android 8 or older
  2. armeabi-v8a with Android 9 or newer

All other ABI combinations would have to use a special version that is too big to be uploaded to the PlayStore. Please reach out to our support team at support@holobuilder.com if you have any further questions.

Supported devices for the JobWalk App

We created a regularly updated list of all supported Android devices. With this list, you can check for any of your devices, whether they are supported by the JobWalk App or not.

Just click the link below and an alphabetically sorted list of supported devices will open in a new tab. If you encounter any problems with the installation of the app, please check if your device is listed.

If the link above does not work properly, please use this link.
Note: Should your device not be found in the list above, this means that, unfortunately, the configuration of your device cannot support the JobWalk app at this moment.

Minimum Device Requirements

There are also certain minimum requirements that your device must meet in order for the JobWalk App to work properly.

  • Mobile devices used for capturing images with the JobWalk app should have at least 2 GB of free storage and 2 GB of RAM.

    Note: The app will warn you if you are running out of memory. Please do not ignore the warning and free up some area (see also below)
  • We recommend one user per device. Each user must always have their own HoloBuilder account in order to avoid conflicts with project versions.
  • In order to free up space locally on the device, we recommend periodically free up the project area (learn more) or deleting the project and re-downloading the “Project Layout” (learn more) so that only the sheets and locations of images (so-called waypoints) are saved in the device. This will prevent the device’s storage from becoming full.

Recommended Android devices

To have the best possible experience while capturing and make use of all our features (e.g. also supporting ARCore for SpeedMode use), the following mobile devices are recommended for use:

Google

  • Pixel 2
  • Pixel 2 XL
  • Pixel 3a
  • Pixel 3
  • Pixel 3 XL
  • Pixel 4
  • Pixel 4 XL

Xiaomi

  • Pocophone F1

Samsung

  • Galaxy S9
  • Galaxy S9+
  • Galaxy S10
  • Galaxy S10+
  • Galaxy Note8
  • Galaxy Note9
  • Galaxy Note10
  • Galaxy Note10+
  • Galaxy Tab S4
  • Galaxy Tab S6

OnePlus

  • OnePlus 6
  • OnePlus 6T
  • OnePlus 7
  • OnePlus 7 Pro
  • OnePlus 7T
  • OnePlus 7T Pro
  • OnePlus 8
  • OnePlus 8 Pro

What might also interest you:

Did this answer your question?